#100 closed defect (fixed)

palette cursors not visible after use of its hotkeys

Reported by: HoraK-FDF@… Owned by: Thomas Bernard
Priority: major Milestone: 2.7
Component: GrafX2 Version: 2.6
Keywords: Cc:

Description

Hi,

the version I'm using is grafx2-win32-2.6.2475-win32.zip from the download page.

if I press the keys to increase/decrease foreground/background color the cursor vanishes.

... greetings HoraK-FDF

Attachments (1)

gfx2_2.7wip2709.png (28.4 KB) - added by Thomas Bernard 15 months ago.
grafx2 win32 2.7wip2709

Download all attachments as: .zip

Change History (17)

comment:1 Changed 19 months ago by Thomas Bernard

Do you have the same behaviour with the sdl version ? ( grafx2-sdl-2.6.2475-win32.zip )

comment:2 Changed 19 months ago by HoraK-FDF@…

It does not happen with grafx2-sdl-2.6.2475-win32.zip

comment:3 Changed 19 months ago by Thomas Bernard

I do not reproduce...

Have you tried with the "nightly build" ?

comment:4 Changed 19 months ago by HoraK-FDF@…

mmh I'm new to gitlab can you please give me a link to there? I have tested grafx2-win32-2.6.2529-issue45-win32 and there its still that way.

comment:5 Changed 19 months ago by Thomas Bernard

grafx2-win32-2.6.2529-issue45 is recent enough.

nightly builds link are available here : http://grafx2.tk/ (but the server is down ?)
or from here : http://grafx2.gitlab.io/grafX2/

comment:6 Changed 19 months ago by HoraK-FDF@…

Thank you for the links and yes http://grafx2.tk/ seems down. Is it possible to add the zip versions on http://grafx2.gitlab.io/grafX2/? Because every time installing grafx2 when only testing is needed wastes much time.

comment:7 Changed 15 months ago by Thomas Bernard

@Horak-FDF :
zip versions are added to https://grafx2.gitlab.io/grafX2/
Do you reproduce with latest build ?

comment:8 Changed 15 months ago by HoraK-FDF@…

Hi,

its still not working in version grafx2-win32-2.7wip2709-win32.

comment:9 Changed 15 months ago by Thomas Bernard

I just tested with the win32/win32 2.7wip2709 version on a Win7 machine and using the keys to incr/decr foreground or background colors works as intended. The outline of the palette index selected are updated correctly.

Changed 15 months ago by Thomas Bernard

Attachment: gfx2_2.7wip2709.png added

grafx2 win32 2.7wip2709

comment:10 Changed 15 months ago by Thomas Bernard

maybe you have a special configuration for your palette display ? could you attach a screen capture ?

comment:11 Changed 14 months ago by Thomas Bernard

Received by email :

I updated my old version of GrafX2 (2.0 beta from 2012) to the latest (2.7wip2744). I noticed that the color selection rectangle disappears when I change a color using keyboard shortcuts: [ or ]. I tried the earlier version but same thing happens. It makes the work very difficult as I can't see which color I'm actually on.
After some experiments I discovered that the problem does not exist only if I choose Menu_ratio = 0 (do not adapt). However, on my full HD 14" screen the buttons are too small so I prefer to use Menu_ratio = -2 (stretch by x2 maximum). And then the problem occurs.
The old version has no problems with it. Can this be corrected please?

comment:12 Changed 14 months ago by Thomas Bernard

I now reproduce with the win32 API version (but not the SDL one)

comment:13 Changed 14 months ago by Thomas Bernard

it looks like it only happens with non separated palette colors
Separate_colors = no in .ini file

comment:15 Changed 14 months ago by Thomas Bernard

Milestone: 2.7
Owner: changed from pulkomandy to Thomas Bernard
Status: newaccepted

comment:16 Changed 14 months ago by Thomas Bernard

Resolution: fixed
Status: acceptedclosed

ok it is confirmed to be fixed, now :)

Note: See TracTickets for help on using tickets.