#117 closed defect (fixed)

palette editor uses wrong colors after save

Reported by: HoraK-FDF@… Owned by: Thomas Bernard
Priority: major Milestone:
Component: GrafX2 Version: 2.7
Keywords: Cc:

Description

Hi,

this is on grafx2-*-2.7wip2709-win32 versions:

when saving a palette (I saved as .pal) the gui turns to strange colors because its uses the last four colors even if there are colors that are near the safe colors. After exiting the editor the gui is normal again.

Attachments (1)

gfx2-paleditor-bug-01.png (19.3 KB) - added by HoraK-FDF@… 14 months ago.

Download all attachments as: .zip

Change History (9)

comment:1 in reply to:  description Changed 14 months ago by HoraK-FDF@…

Replying to HoraK-FDF@…:

Hi,

this is on grafx2-*-2.7wip2709-win32 versions:

when saving a palette (I saved as .pal) the gui turns to strange colors because its uses the last four colors even if there are colors that are near the safe colors. After exiting the editor the gui is normal again.

edit: I can also alter the palette to less colors than safty colors and the gui stays that way even after leaving the editor and this works with Safety_colors = yes so there is also something wrong?

comment:2 Changed 14 months ago by Thomas Bernard

can you attach a palette/picture to reproduce easily the bug ?

comment:3 Changed 14 months ago by HoraK-FDF@…

any picture / any palette

Changed 14 months ago by HoraK-FDF@…

Attachment: gfx2-paleditor-bug-01.png added

comment:4 Changed 14 months ago by HoraK-FDF@…

when loading a palette it also turns for 1 sec to strange colors but then set it right so there is only the thing missing that sets the gui colors for save?

comment:5 Changed 14 months ago by Thomas Bernard

Owner: changed from pulkomandy to Thomas Bernard
Status: newaccepted

comment:6 Changed 14 months ago by Thomas Bernard

it needs to be tested with a palette that has "bad" colors in the last 4 indexes.

It looks like the bug is fixed with the fix for #121
https://gitlab.com/GrafX2/grafX2/merge_requests/206
see https://gitlab.com/miniupnp/grafX2/-/jobs/219737257/artifacts/browse

comment:7 Changed 14 months ago by HoraK-FDF@…

It seem to doesn't occur anymore, I also removed the last four colors and it did right.

but its still possible to alter the palette to less colors than safty colors and the gui stays that way even after leaving the editor and this works with Safety_colors = yes. Should this be moved to a new ticket?

Last edited 14 months ago by HoraK-FDF@… (previous) (diff)

comment:8 Changed 13 months ago by Thomas Bernard

Resolution: fixed
Status: acceptedclosed

yes separate issue must be put in a new ticket.
I believe I remember there was a ticket about Safety_colors...

Note: See TracTickets for help on using tickets.