Opened 5 years ago

Closed 17 months ago

#17 closed defect (fixed)

'Save As' sometimes destroys old file.

Reported by: finticemo Owned by: yrizoud
Priority: critical Milestone: 2.6
Component: GrafX2 Version: 2.4
Keywords: Cc:

Description

I'm not very clear on the circumstances in which this happens, but sometimes:

  • I have a file already saved, a.png
  • I make a lot of changes and save it as a new file, b.png
  • a.png is now gone. There is usually a file a.BAK, so the content is not lost. Nevertheless, this is problematic: I don't expect to have to look around for BAK files to find the content I had already saved to a.png.

To be clear, this is only *sometimes*. I've created 80+ icons in the past two days and only 4 of those suffered this effect.

I'll add more detail to this report as I work it out.

Change History (7)

comment:1 Changed 5 years ago by finticemo

This is still elusive, but I think the bug is related to loading the same file in both spare page and main page, and later saving one of them under a different name.

comment:2 Changed 5 years ago by finticemo

Okay, pretty sure I understand this now:

It occurs every time that I perform 'Save as' and select a pre-existing file (b.png) to save over. Once that happens, the old file (a.png) is nuked.

This can be really annoying when modifying a set of similar icons.

Last edited 5 years ago by finticemo (previous) (diff)

comment:3 Changed 5 years ago by yrizoud

Owner: changed from Adrien Destugues to yrizoud
Priority: majorcritical
Status: newaccepted

comment:4 Changed 2 years ago by Thomas Bernard

I fail to reproduce this with latest source https://gitlab.com/GrafX2/grafX2/commit/ee322ed4371055b1fa7e81e7e0068a83981022bd

I'm using FreeBSDand tried to save to an already existing png file as you describe

comment:5 Changed 2 years ago by PulkoMandy

Milestone: 2.52.6

comment:6 Changed 19 months ago by Thomas Bernard

Does someone reproduce the issue with a recent GrafX2 version ?
If not, I think we can close the issue !

comment:7 Changed 17 months ago by Thomas Bernard

Resolution: fixed
Status: acceptedclosed

I close now because nobody reproduces. I think it is fixed.

Do not hesitate to reopen if you reproduce.

Note: See TracTickets for help on using tickets.