Opened 3 years ago

Closed 3 years ago

#67 closed defect (duplicate)

Palette "Load" Doesn't Seem to Work

Reported by: dpg07131978@… Owned by: pulkomandy
Priority: major Milestone: 2.5
Component: GrafX2 Version: 2.5
Keywords: palette loading Cc:

Description

I am able to save an images palette into a PAL file but when I try to apply a saved palette to an image, replacing that images palette with the one I saved, that functionality doesn't work.

https://weirder-earth-storage.s3.amazonaws.com/media_attachments/files/000/185/856/original/6d665ef11d836cd1.png

Change History (5)

comment:1 Changed 3 years ago by PulkoMandy

Does it work if you use the main load button? (like for lading a picture)

comment:2 Changed 3 years ago by dpg07131978@…

Yes! loading a palette does work when it is loaded using the main interface Load button. However, the option for a PAL file doesn't exist in the pull-down list. I was able to load a palette using the "*.*" option (to be able to see all files), then finding another palette and loading it in. I have also noticed it seems selecting any indexed color image can also be used to change the palette.

While this behavior works it does now seem kind of ambiguous as to what is really happening. I am no longer blocked however. Thanks for the tip. Not sure if this bug still qualifies as critical.

comment:3 Changed 3 years ago by Thomas Bernard

isn't it a duplicate of http://pulkomandy.tk/projects/GrafX2/ticket/24 ?
maybe if the menu color remapping issue is not blocking, we could merge https://gitlab.com/miniupnp/grafX2/tree/load_palette into master ?

comment:4 Changed 3 years ago by dpg07131978@…

You are correct. This is a duplicate of http://pulkomandy.tk/projects/GrafX2/ticket/24

comment:5 Changed 3 years ago by PulkoMandy

Resolution: duplicate
Status: newclosed

Duplicate of #24 (hint: you can use #number to refer to other tickets)

Note: See TracTickets for help on using tickets.