Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#77 closed defect (duplicate)

Odd brush selection heavior since f2d579695cf78bf3e538383bd5843347be0c6acf

Reported by: Philip Linde Owned by: pulkomandy
Priority: major Milestone: 2.6
Component: GrafX2 Version: 2.5
Keywords: brush selection Cc:

Description

I noticed in newer versions that selecting a brush now uses two mouse crosshairs instead of the traditional crossed lines box. After finishing brush selection, the crosshair marking the first selection corner stays visible until I hover over it with some brush to "flush it out". I could repeat this in Windows, Linux (x64) and Morphos.

So I did a git bisect and found that the issue was introduced with commit f2d579695cf78bf3e538383bd5843347be0c6acf, which refers to issue #54.

I have attached a screenshot that shows how the page looks just after selecting a brush. The lower shape is the brush attached to the mouse, the upper is where I selected it from, and the upper crosshair is the crosshair left by the brush selection operation. This only seems to happen if the current brush isn't a custom brush.

I think a good look should be taken at the commit that introduced the issue to find the cause. I will have a look myself, but hopefully the author of the patch can figure out the cause much faster.

Attachments (1)

brush.png (12.2 KB) - added by Philip Linde 3 years ago.
Screenshot of residue from brush selection

Download all attachments as: .zip

Change History (3)

Changed 3 years ago by Philip Linde

Attachment: brush.png added

Screenshot of residue from brush selection

comment:1 Changed 3 years ago by PulkoMandy

Resolution: duplicate
Status: newclosed

Duplicate of #75, but thanks for reporting.

comment:2 Changed 3 years ago by Philip Linde

Thanks, I have added some additional information to #75

Note: See TracTickets for help on using tickets.