#87 closed defect (invalid)

Crash: GrafX (win32) crashes on attempting to set palette format, during palette load.

Reported by: zoriarpg@… Owned by: pulkomandy
Priority: major Milestone: 2.6
Component: GrafX2 Version: 2.5
Keywords: Cc:

Description

Issue: GrafX crashes (hard crash, instantly) if you click on the 'Palette Format' (file type) widget, in the 'Load Palette' dialogue.

System Information : Windows 10, v. 10.0.17134, build 17134
(Please inform me, if you need other, more-specific details, for drivers and libs.)

Specific GrafX build: v2.0, build '96.5%'. (2-2.5.1949), win32

How to Reproduce:

  1. Launch GrafX2
  2. Click the 'Pal' button.
  3. Click the 'Load' button.
  4. Click on the 'Format' drop_down proc. At this point, GrafX2 instantly and abruptly terminates.

Suspect: Uninitialised data, or invalid pointer refs.

P.S. I posted this issue on GitHub?, and to *my* dashboard on GitLab?. I am not familiar with the GitLab? UI, so I'm not sure if you can see that one, or if you will be notified of it; and I do not know if you still track them on GitHub?.

Change History (5)

comment:1 Changed 21 months ago by zoriarpg@…

Summary: Crash: GrapfX (win32) crashes on attempting to set palette format, during palette load.Crash: GrafX (win32) crashes on attempting to set palette format, during palette load.

comment:2 Changed 21 months ago by Thomas Bernard

This is very probably a bug that has been already been fixed.
please check with the nighlty build which is 2.6wip2249 today !
https://gitlab.com/GrafX2/grafX2/-/jobs/artifacts/master/browse?job=job_win32

comment:3 Changed 21 months ago by Thomas Bernard

I'm pretty sure I remember fixing this one...
must be this commit : https://gitlab.com/GrafX2/grafX2/commit/6e6f8ca3f404d0868abd32ba2a154f3f3f18a839

the fix was fixed again here :
https://gitlab.com/GrafX2/grafX2/commit/5e4d2f570031304139d2e1fbfcad0e19078c5e69

GUI bugs may depend on your Window size, pixel size (1x1, 2x2, etc.) and "menu ratio"

Last edited 21 months ago by Thomas Bernard (previous) (diff)

comment:4 Changed 21 months ago by zoriarpg@…

Seems to be fixed. Is there a convenient change log for these builds?

comment:5 Changed 21 months ago by Thomas Bernard

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.