Opened 6 years ago

Closed 4 years ago

#34 closed defect (fixed)

Latency on mouse pointer when running Grafx2 in Windows 10

Reported by: demofrost Owned by: PulkoMandy
Priority: major Milestone: 2.6
Component: GrafX2 Version: 2.4
Keywords: Cc:

Description

I recently upgraded from Win7 to Win10 and since that there is some latency on the mouse pointer in Grafx2. This is such a big problem that I can't stand using Grafx2 in Win10.
I did not have this problem when running Grafx2 in Win7.

Change History (8)

comment:1 by pulkomandy, 6 years ago

There are some settings you can try to adjust in the INI file:

  ; The sensitivity of the mouse can  | La sensibilitde la souris peut
  ; take values from 1 to 4. The      | prendre des valeurs de 1 4. Plus
  ; smaller values, the faster.       | les valeurs sont petites, plus c'est
  ; This only takes effect in         | rapide. Ce paramrage n'est utilis
  ; fullscreen modes.                 | que dans les modes "plein ran".
  ;                                   | 
  X_sensitivity = 1     ; (default 1)
  Y_sensitivity = 1     ; (default 1)

  ; This setting allows you merge successive mouse movements into a single
  ; mouse movement. You should only use it if you are using a mouse which
  ; reports at 200Hz or more, and you experience lag when using discontinuous
  ; hand-drawing with large brushes (this tool tries to paste the brush and
  ; update the screen on each new mouse position) In this case, set this to 2
  ; or more, to ignore some intermediate mouse reports when a more recent one
  ; is present.
  ; Note that with a value superior to 1, you lose precision with continuous
  ; hand-drawing, as intermediate mouse positions are skipped.
  Merge_movement = 0 ; (default 0)

The second one can also be changed in the settings menu.

comment:2 by PulkoMandy, 5 years ago

Milestone: 2.52.6

comment:3 by PulkoMandy, 5 years ago

Owner: changed from Adrien Destugues to PulkoMandy
Status: newassigned

comment:4 by Thomas Bernard, 5 years ago

I'm eager to know if there is the same issue with the Win32 "GDI" build of GrafX2

comment:5 by PulkoMandy, 4 years ago

Anyone has feedback on the native GDI or the SDL2 builds? Do they make things better?

comment:6 by Thomas Bernard, 4 years ago

I think we should close the issue.
we can always reopen it if the problem is still there.

comment:7 by PulkoMandy, 4 years ago

Milestone: 2.62.7

Move open tickets to 2.7 milestone

comment:8 by Thomas Bernard, 4 years ago

Milestone: 2.72.6
Resolution: fixed
Status: assignedclosed

closing. Nobody complained lately
please re-open if you still have issues

Note: See TracTickets for help on using tickets.