Opened 2 years ago

Closed 18 months ago

#74 closed defect (fixed)

Superbucketfill (Replace col. (Shift+F)) unusable in magnified mode

Reported by: Adrian Castravete Owned by: PulkoMandy
Priority: major Milestone: 2.6
Component: GrafX2 Version: 2.4
Keywords: Cc:

Description

Description:

On recent versions from master, when I try to use the Replace colour function I can no longer place a colour in the magnifier window. Well I can, but I see no cursor updates. I noticed that if I am not zoomed in, and the image is large enough, I can use the left side vert well and the magnification window follows the centre of the magnification rectangle on the left side, though.

Actual behaviour:

The cursor disappears and the screen looks frozen if the zoom level is smaller than the display area.

Expected behaviour:

At least the old behaviour where I would see the cursor and not be forced to have the magnification window enable would be nice.

Steps to reproduce:

  • Open GrafX2
  • Select a small sprite size, for example 32x32
  • Open magnification (M)
  • Select Replace Colour (Shift+F)

Change History (6)

comment:1 Changed 2 years ago by PulkoMandy

Milestone: 2.52.6

comment:2 Changed 2 years ago by PulkoMandy

Owner: changed from pulkomandy to PulkoMandy
Status: newassigned

comment:3 Changed 19 months ago by Thomas Bernard

I just tested with the latest master, and I do not reproduce the issue.

I created a 32x32 image. Open magnification
The replace colour works as intended.

Can you tell me if you still have the issue with the latest master.
If that is the case, please tell me what is your GrafX2 build (linux/Windows ? SDL, SDL2, GDI, X11 ?)

Thanks

comment:4 Changed 19 months ago by PulkoMandy

I think this was related to the wrong cursors bug in GRafX2.5. At least the symptoms seems to match.

comment:5 Changed 18 months ago by Adrian Castravete

Hello! :) After seeing your replies and pulling everything to the latest it seems this problem is no longer.

Indeed when looking at what I had installed, the splash screen says 2.5 and now 2.6wip.

comment:6 Changed 18 months ago by PulkoMandy

Resolution: fixed
Status: assignedclosed

Thanks for reporting!

Note: See TracTickets for help on using tickets.